在64位Debian/Ubuntu系统上安装WPS for Linux

在64位Debian/Ubuntu系统上安装WPS for Linux

作者:admin 时间:2013-04-03 分类:服务器 评论:0条 浏览:6932
 wps for linux

wps for linux

WPS for Linux是一款为Linux系统打造的Office软件。与Microsoft Office高度兼容,除延续Windows版相同体验外,更加尊重Linux用户特定的使用习惯,里面自带方正字体集;在线模板和素材使文档创作更加轻松高效。
WPS for Linux目前只提供了x86平台32位的安装包,Linux 64 bit用户可以通过安装32 bit的库来获得支持。
Ubuntu 用户:

sudo apt-get install ia32-libs

Debian 用户:

sudo apt-get install ia32-libs ia32-libs-gtk
sudo apt-get install libc6-i386

安装后在命令行敲:wps 看程序能否启动,如果提示
libgthread-2.0.so.0: cannot open shared object file
则要安装ia32-libs-gtk:

sudo apt-get install ia32-libs-gtk


经过以上步骤,Debian 7已经可以正常使用WPS了。对于Debian6(squeeze)用户,还需要:
1、下载libstdc++6的testing或sid版,解包到某个目录(比如/opt/libstdc)
2.修改wps和wpp脚本/usr/bin/wpp和/usr/bin/wps,添加libstdc++6和gtk2的位置,gtk2应当使用/usr/lib32/gtk-2.0
或者考虑添加testing或者Wheezy的软件源, 然后运行“sudo apt-get dist-upgrade”升级一下系统。 软件源举例:

deb http://mirrors.163.com/debian wheezy main non-free contrib
deb http://mirrors.163.com/debian wheezy-proposed-updates main contrib non-free
deb-src http://mirrors.163.com/debian wheezy main non-free contrib
deb-src http://mirrors.163.com/debian wheezy-proposed-updates main contrib non-free

deb http://mirrors.163.com/debian-security wheezy/updates main contrib non-free
deb-src http://mirrors.163.com/debian-security wheezy/updates main contrib non-free

如果遇到错误:

ia32-libs : Depends: ia32-libs-i386 but it is not installable

调用:

dpkg --add-architecture i386
apt-get update

启动后如果提示自体缺失,则要下载下面的自体包:
http://bbs.wps.cn/thread-22355435-1-1.html
下载后将字体解压到/usr/share/fonts/wps-office目录,然后重启wps即可。

RPM 系发行版:
无须介意。rpm系的’.so’ 是动态查找的,32位的 ‘.so’ 自动查找32位的依赖。

原创文章,转载请注明: 转载自www.webmaster.me

本文链接地址: 在64位Debian/Ubuntu系统上安装WPS for Linux

标签:

相关推荐
更多

smarty实例教程(喜悦国际村) —模板设计部分
Posted on 08月13日
linux top命令简介
Posted on 02月18日
为FreeBSD设置网卡IP,网关和DNS
Posted on 04月12日
Base64加密方法
Posted on 12月15日

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*